Your login for our support center is different than your Control Panel login.

Click here to create a login for the support center

 Knowledgebase
Knowledgebase
Hurricane MTA Server 2.0 Upgrade Guide

Requirements

The system requirements for Hurricane MTA Server 2.0 are the same as 1.x with the exception that 2.x requires that the .Net 4 framework be installed.  Hurricane MTA Server 2.0 cannot be implemented unless the .Net 4 framework has been previously installed.  Please visit the Microsoft website to download the .Net 4 framework if you have not already done so.

Upgrade Process

To upgrade to Hurricane MTA Server 2.0, simply download the 2.0 setup.exe file from our website at http://download.socketlabs.com/hms/2/setup.exe.  It is important that you save the file to your local computer and then execute it from there.

If you have a previous version of Hurricane MTA Server on your system, the setup application will install version 2.0 over top of it, and preserve all of your settings.  We strongly recommend that you backup your 1.x installation prior to the upgrade.  It is not possible to do a side-by-side installation of 1.x and 2.x.

If you are upgrading from a version of Hurricane MTA Server prior to 1.0.0.846 on a 64 bit system, please see the following knowledgebase article:
https://support.socketlabs.com/index.php/Knowledgebase/Article/View/55/0/32-to-64-bit-upgrade

Reverting back to 1.x

If you have upgraded to 2.0 and you wish to revert back to 1.x, you can re-download the 1.x setup.exe file from our website and execute it locally.  This will install the latest version of 1.x to your system and will preserve your settings.  Keep in mind that the latest version of 1.x may be more recent than the version of 1.x you were using prior to your 2.x upgrade.  If you need to restore to the exact same version you were running prior to your 2.x upgrade, you will need to restore from a backup of the Hurricane MTA Server directory prior to the upgrade, but beware that your backup of the Hurricane MTA Server directory will contain the entire Hurricane MTA Server state at the time of the backup, including settings, messages in queue, etc.

Upgrading to newer builds of 2.x

Once you have 2.0 or higher installed, you can simply update to the latest version of 2.x in one of two ways: 1) use the “Update or Uninstall” shortcut on the Hurricane MTA Server start menu program group, or 2) re-download the setup file from our website and execute it locally.


Comments (0)
Help Desk Software by Kayako  Copyright © 2019 SocketLabs, Inc.  Terms of Service | Privacy Policy | Acceptable Use Policy