Your login for our support center is different than your Control Panel login.

Click here to create a login for the support center

 Knowledgebase
Knowledgebase
HMS System Requirements

Before Installing a Hurricane MTA Server

The Hurricane MTA Server (HMS) requires one or more pre-installation actions before performing a new installation. There is also a minimal set of hardware requirements in order for the MTA to run at all and recommended hardware in order for it to run at maximum efficiency. 

Hardware Requirements

Regardless of the Operating System being used, we recommend a minimum level of hardware resources in order for the Hurricane MTA Server to perform effectively.

  • System RAM. Minimum of 2 GB. 8 GB or more preferred.
  • Processor. Minimum of 2.0 GHz dual core processor. Performance gains come from both stronger processors and additional cores.
  • Hard Disk Drives. 10-15k RPM drives to prevent long disk queues. Dedicated RAID array also recommended for both speed and prevention of data-loss.

Software Requirements

Please see the appropriate section depending on the operating system to which the HMS software is being installed.

Windows Server 2003

Version 1.x of the HMS requires the following before installation:

  • The latest .NET Framework 2.0

Version 2.x of the HMS requires the following before installation:

  • The latest .NET Framework 4.0
  • The Windows Imaging Component (WIC)

Please note that in order to install the .NET Framework, a prompt for the WIC should appear if it is not currently installed.

Windows Server 2008 R2

Version 1.x of the HMS requires the following before installation:

  • The latest .NET Framework 2.0

Version 2.x of the HMS requires the following before installation:

  • The latest .NET Framework 4.0

Windows Server 2012

Version 1.x of the HMS is not supported on Windows Server 2012.

Version 2.0 of the HMS does not have any pre-installation requirements.

Version 2.1+ of the HMS has the following requirements when selecting the IIS option:

  • From the Add Roles and Features option, navigate to the Server Roles screen and choose the following, accepting any requested dependencies as well:
    • Web Server (IIS)
  • From the same screen, choose the following, accepting any requested dependencies as well. These options may not be visible until after the main Web Server (IIS) option has been installed:
    • Web Server -> Application Development -> ASP.NET
    • Web Server -> Application Development -> ASP.NET 3.5
    • Web Server -> Application Development -> ASP.NET 4.5

Any additional requirements related to using IIS will be handled by the HMS installer itself.

Windows Server 2016

Version 1.x of the HMS is not supported on Windows Server 2016.

Version 2.X of the HMS is not supported on Windows Server 2016.

Version 3.0+ of the HMS has the following requirements when selecting the IIS option:

  • From the Add Roles and Features option, navigate to the Server Roles screen and choose the following, accepting any requested dependencies as well:
    • Web Server (IIS)
  • From the same screen, choose the following, accepting any requested dependencies as well. These options may not be visible until after the main Web Server (IIS) option has been installed:
    • Web Server -> Application Development -> ASP
    • Web Server -> Application Development -> ASP.NET 3.5
    • Web Server -> Application Development -> ASP.NET 4.6

Any additional requirements related to using IIS will be handled by the HMS installer itself.

Performance Recommendation

It is highly recommended to choose the IIS web server over the embedded Cassini web server when installing this version of the MTA. IIS provides a much more robust configuration interface through Microsoft’s IIS Manager, and performance is far superior compared to Cassini.

Additional Reading

.NET Framework 2.0 Standalone Installer

http://www.microsoft.com/en-us/download/details.aspx?id=1639

.NET Framework 4.0 Standalone Installer

http://www.microsoft.com/en-us/download/details.aspx?id=17718


Comments (0)
Help Desk Software by Kayako  Copyright © 2018 SocketLabs, Inc.  Terms of Service | Privacy Policy | Acceptable Use Policy